[Case ID#: 61606] Lumerical MODE ver 7.9.1044 on Window 8_Crashes during material check/simulation run


#1

Hi,

I am currently taking UBCx: Phot1x Silicon Photonics Design, Fabrication and Data Analysis on edX.

After installing Lumerical MODE, I tried to run an example of “Y Branch”. I stepped through the example of the tutorial video and the software crashed when I try to do material check (step 7).

  1. GDS Layout import of the Y-Branch geometry; material settings

  2. VarFDTD solver; simulation volume; PML boundaries;

  3. Mode source at the input waveguide; wavelength settings

  4. Check slab mode profile in varFDTD, as in the Effective index method Mode

  5. source profile Monitors;

  6. frequency-domain field and power in output waveguides

  7. Check “core” effective index of slab waveguide

  8. Run 2D FDTD simulations

  9. Visualize transmission versus wavelength

I tried to skip material checking (step 7) and tried to run the simulation (step 8) but the software crashed as well.

I tried to skip material checking (step 7) and running of simulation (step 8) and save my profile file but the software crashed as well. So I was unable to send a profile file to you.

I attached the Y branch GDS I downloaded from the course for your reference and below are the message I got when the software crash:

Compact_YBranch_open.gds (12 KB)

One more piece of information. I was actually able to run the script provided by the course on Y branch (attached). However, I was unable to reopen the output files (attached) without running the script again. Hope this information is useful for Lumerical to help debug my issue.

Ybranch_varFDTD_3DFDTD.lsf (12.2 KB)

Ybranch_FDTD.lms (269.7 KB)

Thank you and Hope I can get a solution as soon as possible.

Regards,
Johnny


#2

Dear @tiongleh.yap

Thank you for reaching out and I am very sorry for the inconvenience. Unfortunately it is a bug in 2017a MODE Solutions solver. While we are working on to fix the bug, I come up with two workarounds that hopefully can solve the problem momentarily.

1) It looks like the software crashes when you add the Frequency-domain field and power monitor and you want to run simulations. I found out that if you introduce a Mode expansion monitor into your simulation region and then add the Frequency-domain field and power into Monitors for expansion (in Edit tab for mode expansion monitor), as in the screenshot below, it will solve the problem:

2) If your license is not trial, you can download the previous version (2016b) of the software from here and then selecting the Previous Release for the version as in the screenshot below. This version should work without a need for Mode Expansion monitor.

Sorry again for the inconvenience and hopefully this workaround was helpful.
Best of luck in the course.


#3

Dear @tiongleh.yap

Thanks to our team, the problem is solved. You can expect the new version to be updated soon, hopefully within a week, and you can use it with no further issues. Sorry again for any inconvenience.


#4

The fix for this problem has been released in 2017A R2. To solve this issue, simply download and install the latest version of Lumerical tools available here:
https://www.lumerical.com/downloads/


#5