Cannot stop the simulation running of INTERCONNECT


#1

Hi there, I have a problem when running INTERCONNECT simulation. After I clicked the “run” button, the simulation runs forever and could not be stopped. Also, the “file” and “edit” tabs at the top are greyed out. Any idea on the cause of this problem and how to solve this problem? Project file bug_test.icp (163.6 KB).


#2

The project file seems to be running ok on my computer.

I suspect that the problem might be due to the following reasons:

  • the project file is not saved yet
  • the “monitor data” (in “Root Element -> Enhanced”) is set to “save to disk”, instead of “save to memory”
  • you don’t have the write permission to the current working directory

If the above assumptions are all true, you might need to change one of them.

Also, in your case, to stop the simulation, you could try adding a new element into the schematic editor, which will force INTERCONNECT switch to design mode.

Hope this helps.


#3

@xwang, Thanks for the reply. Adding another element did successfully stop the running of the simulation. However, the “File” and “Edit” tabs are still greyed out so that I cannot save the file let alone to other directories. Any idea on how to solve this?


#4

@gwang That seems like a minor bug. You can still save it using the keyboard (“Ctrl + S”) to another directory where you have the write permission.

The only approach to get back the “File” and “Edit” menus seems to be switching from “save to disk” to “save to memory” and re-run the simulation.