Asked for .NET framework 2.0 when trying to install

dotnet

#1

I received my new floating license and tried to install Lumerical on a server. The license manager appears to install OK and the license appears to have been activated. However, when I try to install the tools (e.g. MODE), the installer gives me a message saying that .NET framework 2.0 is needed. (I checked the server, it only has .NET framework 4.5.) Do I simply install .NET framework 2.0 then?
Why does it need such a earlier version of .NET, and why no one else mentioned this problem?

Chuan


FDTD.exe is not running
#2

chuan.xie,

For recent Windows versions, it comes with version 4 or higher.
Lumerical product application requires .Net 3.5. Unfortunately, which is not compatible with the newer versions, and Windows requires .net 2.0 to install .net 3.5.

To install the required version, please to add this feature. Please refer to the following articles:

For Windows 7:

For Windows Server 2012:

For Windows 8 and 10.
Follow the installation for Windows 7, to enable the feature from the Control Panel.

This feature will be installed via windows update.

Cheers,
Lito


#3

Thanks, Iyap. My server has Windows Server 2012 R2. Let me try to follow your instructions on Windows Server 2012 installation.

Chuan


#4

Please let us know how things work out for us. We look forward to your feedback.
Thanks,
-Lito


#5

Hi Lito,
Thanks for following up. I had to ask IT to install .NET framework 3.5 on the server (because when I tried following your instructions, it asked for source files), then the installation completed with any problem. I tried MODE yesterday and it worked fine.

Regards,

Chuan


#6

We are glad that everything worked out fine for us.
Cheers,
Lito