Adding a new material


#1

i am working with amorphous silicon, so i tried to add this material by collecting optical constants from the handbook of optical constants of solids. to import data, first i created a .txt file. when i imported the data only 20 data came but there were more than 20 data.


also when i ran the simulation, this error came. the simulation ran successfully with the built in Si-palik material.
what is the solution? any help will be really appreciated. thank you.


#2

Hi, @mrinmoy !

Could you, please, provide the files you used ?


#3

Hi @mrinmoy
I found in Lumerical’s knowledge exchange two similar topics. the first is Add material model for amorphous silicon in DEVICE and the second is here the properties of the amorphous silicon and the polysilicon. As @bkhanaliloo has already said there is not definitive value for amorphous silicon. We could investigate it further.


#4

dear @konslekk
thanks for your reply. i already read those two topics. i tried to add amorphous silicon to the material data base myself by taking optical constants from’ handbook of optical constants of solids’. i imported some data for the material but after using the material i faced some errors. i wanted to know what caused those errors so that i could solve them.


#5
ss.txt (398 Bytes) In-TiO2 thickness opt (2).fsp (2.2 MB) first one is the txt file i used to import data of amorphous silicon and second one is the fsp file. thanks :slight_smile:

#6

FYI your text file is missing a decimal point on line 21, you have “9 655” instead of “9.655”.
That could be the cause of your problem.


#7

@ie5003_allison is write about the file.
I run the simulation with the “TiO2…” disabled and it worked without any error.
This group turned out to be the cause of the problem.
Try to construct the model more thoroughly and ask further question as they occur.