2d simulation works, however in 3d returns odd data


#1

Hi, I have never used this before so hope this is the right place and format.
I am a new PhD student that inherited a lumerical model for a waveguide. I rewrote it to understand it and in 2D it runs well and I see sensible results (transmission~70% and a nice E-field distribution).
However I cant replicate this result in 3D. It runs without error, however there is no transmission and the E-field shows the energy dispersing immediately with no waveguiding.

Are there any obvious problems I should be aware of or common issues?

I can give a more detailed account, but dont know what is relevant.
Thanks!


#2

Dear @md12g12

Thank you for reaching out. There can be different reasons, and I guess the easiest way for troubleshooting would be to share your simulation file with us so that we can take a look at it.

Thanks


#3

Hi, and thanks for the response, sorry for the late reply!

Here is the script file, (from which everything is run) the model file is too big to upload but this should work running on its own.
At the start of the script there are some commands specific to how I run files here (pathway names to lumerical licence and number of cores etc) but im sure you can remove them so it will run on any lumerical machine. If not let me know and I will try and remove them.

I hope this is enough to go on, if not let me know what else I should send.

Thanks!
1x2MMI_perturbed.lsf (19.5 KB)


#4

Dear @md12g12

I ran the simulation run and I noticed that you are not injecting a proper waveguide mode (it has a small size). I increased dimension to be ~6um wide on the y and ~1um on the z and here is how it should look like:

Then I added a DFT monitor and I could see that the light is propagating along the devices: (since the simulation will take long, I didn’t wait long enough):

Please do modifications and run the simulations. I am guessing that these adjustment will solve the problem but please let me know if you still have any problem.

BTW, 500 lines of code, that was impressive! If you are not too familiar with the software, it will be a good idea to spend some time with getting started KB examples.

Thanks


#5

I have changed it and yes it runs great. Thanks for your help!


#6

Dear @md12g12

I am glad that we could solve the problem. Best of luck.

Thanks